We're updating the issue view to help you get more done. 

Document using Let's Encrypt on EL6

Description

From https://support.opensciencegrid.org/a/tickets/10135, we don't have information on how to use Let's Encrypt certs on EL6 because certbot is not available in standard repos.
Our instructions do work with the certbot-auto script mentioned at https://certbot.eff.org/docs/install.html#alternate-installation-methods so we should mention that.
Because of the nature of the script (you download it from the web and it can update itself), we should add the following advice:

  • Use the instructions on the site to verify the script after downloading it

  • Modify the cron job to add --no-self-upgrade to the command line.

Environment

None

Target metrics

None

Personnel

None

Freshdesk Tickets

None

Status

Assignee

Brian Lin

Reporter

Mat Selmeci

Priority

Major

Labels

None

Components

Fix versions

None

Epic Link

None