osg-wn-client fails to install because of conflicting dependencies

Description

With OSG 3.5 (and presumably for 3.4), the osg-wn-client installation fails due to a new release of xrootd4 in EPEL:

We believe that this is because gfal2 requires XRootD through .so and so Yum priorities aren’t preferring our package over EPEL’s.

Freshdesk Tickets

None

Activity

Show:
Brian Lin
November 12, 2020, 4:23 AM

Goulash and grog! You’re cleared to promote.

Carl Edquist
November 12, 2020, 4:38 AM

Goulash and grog!

It's delish, but at 10$/mug, i am not making a grog bet...

Promotions
Promoted gfal2-2.18.1-1.1 to osg-3.4-el*-testing, osg-3.5-el*-testing

Build

Tag

gfal2-2.18.1-1.1.osg34.el6

osg-3.4-el6-testing

gfal2-2.18.1-1.1.osg34.el7

osg-3.4-el7-testing

gfal2-2.18.1-1.1.osg35.el7

osg-3.5-el7-testing

Brian Lin
November 12, 2020, 7:03 AM

Since Marco was recently bit by a bug like this, I’ve asked if he could test it for us: https://support.opensciencegrid.org/a/tickets/65974

Tim Theisen
November 12, 2020, 2:21 PM

Marco tested it and I tested it. Test passed.

Tim Theisen
November 12, 2020, 2:34 PM

Promotions
Promoted gfal2-2.18.1-1.1 to osg-3.5-el*-prerelease, osg-3.4-el*-rolling, osg-3.5-el*-rolling, osg-3.4-el*-prerelease

Build

Tag

gfal2-2.18.1-1.1.osg34.el6

osg-3.4-el6-prerelease

gfal2-2.18.1-1.1.osg34.el6

osg-3.4-el6-rolling

gfal2-2.18.1-1.1.osg34.el7

osg-3.4-el7-prerelease

gfal2-2.18.1-1.1.osg34.el7

osg-3.4-el7-rolling

gfal2-2.18.1-1.1.osg35.el7

osg-3.5-el7-rolling

gfal2-2.18.1-1.1.osg35.el7

osg-3.5-el7-prerelease

Fixed

Assignee

Tim Theisen

Reporter

Brian Lin

Priority

Blocker

Fix versions

Labels

None

Components

Due date

None